May 24, 2020

English | 日本語

racer 2.1.34 でビルドエラー (日本語)

自分は良く rust のコードを書く際に”racer” をコード補完に使っている。

いつもだったら racer をインストールするのは以下のように簡単だ。

$ cargo +nightly install racer

(“cargo” は rust のビルドツール)

しかし、最近このビルドがコケる。

racer の現在の最新バージョンは 2.1.34。 ためしに 1 個前のバージョンの 2.1.33 を試してみたら成功した。

$ cargo +nightly install --version 2.1.33 -- racer

GitHub issue を見る限りこういったトラブルは少なくない模様。 まあ rust のテストバージョンである nightly toolchain を使ってるし仕方ないよな。

コミッターの人たちもすぐに気付くだろうしバグ報告は挙げない事にした。